HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aborting faxes

Nico Garcia wrote:
> On Sat, 15 Nov 1997, Yves Trudeau wrote:
> > I have a similar problem to. I use v4.0pl1 on Linux 2.0.29. Everythings
> > works fine when hylafax is idle but if there is jobs in the sendq it's a
> > different story. I tried "faxstate cua1 -s down", "TimeOfDay:
> > 0500-0530" in config.cua1 (I need the modem between 5:00 and 5:00 AM)
> > and faxquit with no success. If faxgetty is no running on cua1, faxq
> > will in fact exit after the "faxquit" command... only after all the jobs
> > in sendq are done. We do a lot of broadcast faxing so there is always
> > jobs in sendq. I have already hack faxq in order to make it generate a
> > "faxq.pid" files which a can use to kill it but this means that the
> > current jobs will not be notified. Any input is greatly welcomed.
> Hmm. Are you using a faxgetty entry in your inittab? And I am confused
> that these programs should *not* respect the HylaFAX lock state, and
> vice versa. What exactly do you need to use as well as HylaFAX, and
> where is it putting the lock files? Remember: just because they are on
> the Linux CD or web sites does not mean they are configured
> identically.
>                         Nico Garcia
>                         Engineer, CIRL
>                         Mass. Eye and Ear Infirmary
>                         raoul@cirl.meei.harvard.edu

Following the suggestion of Matthias, I put a TimeOfDay restriction in
etc/config and it is effective. The only drawback is that we have many
fax lines connected to this server and... they all stop sending faxes
during the restriction. The other program I want to use is pppd. The
lock files are OK, these programs never attemp to use the modem at the
same time. The problem is that I want Hylafax to release one of the
modem at a given time for pppd, and, when there are jobs in sendq (we
have a large clients database, 10000+), I found that it is quite hard to
do this. In the last few days I tried a lot of things:

Without faxgetty running on cua1


OK, faxq starts and there is no faxes going out

#faxstate -s ready -n cua1

OK, cua1 starts sending faxes

#faxstate -s down -n cua1

Absolutely no effect... (after 10 minutes, still sending faxes)
Let's try something else,

#faxquit cua1
FIFO.cua1: open: No such device or address

I suppose this is due to the absence of faxgetty?
Another try!


OK, faxq is dead.

Now, I tried the same with 2 modems sending faxes and... 

#faxstate -s ready -n cua1
#faxstate -s ready -n cua2

Now, faxquit is ineffective. The only way to stop now is to kill faxq or
using faxconfig TimeOfDay: "0000-0001". I think (from what I have seen
and understand from the source file faxQueueApp.c++) that faxq wait
until there is no active job before exiting. This is a good behavior as
long as is does not continue to dial new jobs. With more than one modem,
there is almost always a job going on one of the modems. Is it possible
that faxq does not check if quit is true before making a job active. As
you can see... I am not an expert in c++.

The story is similar with faxgetty running (execpt for the FIFO error).

Thank you in advance,


Yves Trudeau, Ph. D.
Jyrmatec Inc.
1381, Jolliet
Sherbrooke, Québec
Canada, J1K 1Y8
Tel.:(819) 565-8349
Fax.:(819) 565-8273
email: ytrudeau@jyrmatec.com

Project hosted by iFAX Solutions