HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sendfax doesn't work when in startup script

Hi Rob,

How about installing the client side hylafax binaries on the HP machine and
running 'sendfax' there instead of 'lp'  Would remove the need for all of
the below.

Or if the purchase order application refuses to print to anything other
than 'lp' create a simple lp script that calls sendfax on the HP, perhaps
passing in the number via the -o param or something.

- Robert

At 02:09 PM 12/15/98 -0600, Rob Embry wrote:
>I have Hylafax working just fine on a RH Linux box as my network based fax
>I have a proprietary database running on an HP-UX box from which I need to
>fax purchase orders (POs).  
>I have solved this problem as follows:
>1.  The database program prints a PO to a print queue called pofax which
>parks a text copy of the PO in a directory on the Linux fax server via NFS.
>2.  A fax monitor program (written in perl) on the Linux box monitors the
>pofax queue directory.
>3.  When a PO text file shows up, the monitor program spawns (using a
>"system" call) another perl  process called faxit which reads the text PO
>file, does some fancy merging with a PS-based forms mask, and calls sendfax
>(using backquote function call, to capture return code) to fax the merged PS
>The problem:  When I start the monitor program manually from the command
>line logged in as root ("/usr/bin/perl monitor_pgm &"), everything works OK.
>When the monitor program is started from rc.local at system start after a
>reboot, and after hfaxd starts, the sendfax command in faxit fails and
>returns a blank error messages.
>I have tried tweaking every permission and parameter I am aware of to no
>avail.  Clearly the monitor process and its descendants are not getting
>something they need when run from startup.
>Any ideas?
>Thanks in advance,
>Rob Embry
>EMC Test Systems
>Austin, TX

Project hosted by iFAX Solutions