HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

problem compiling hylafax on Redhat 5.2


I've got a problem compiling HylaFAX 4.0pl2 on my RedHat-5.2-System
(gcc, glibc-2.0.7). 

Make produces the following error in hylafax-v4.0pl2/util:

SendFaxJob.c++: In method `unsigned char SendFaxJob::createJob(class SendFaxClient &, class fxStr &)':
SendFaxJob.c++:499: no matching function for call to `SendFaxClient::sendZData (int &, unsigned char (FaxClient::)(fxStr &, fxStr &), fxStr &, fxStr &)'
FaxClient.h:273: candidates are: FaxClient::sendZData(int, unsigned char (FaxClient::*)(fxStr &, fxStr &), fxStr &, fxStr &)
make[1]: *** [SendFaxJob.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/SOURCES/hylafax-v4.0pl2/util'
make: *** [default] Error 2

In the FAQ there was the tip to add /usr/include/g++ to defs.in (Q27). I added
it there an in util/Makefile, but it didn't worked (the same result than

Can anybody help me ?

Bastian Mathes, Tel. +49-451-53247

Project hosted by iFAX Solutions