HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem compiling 4.0pl2 and 4.1b1

Tim Rice wrote:
> On Thu, 29 Jul 1999, Jim Dossey wrote:
> > Tim Rice wrote:
> > >
> > > Something has changed in UnixWare 7.1.0.
> > > I ran into problems using the SCO UDK.
> > > I haven't had time to track down the problem yet bacause
> > > I went back to 7.0.1 to make sure it compiled.
> > >
> > > I can provide binaries in pkgadd(1M) format compiled on
> > > UnixWare 7.0.1 if you are interested.
> >
> > As a side note, I also tried using 4.0pl2 compiled on a 7.0.1 system but
> > it didn't work.  I ran a truss on it and faxq was getting an EAGAIN
> > error when it tried to fork.
> Make sure your port.h has #define CONFIG_MAXGID 60000
> That's one of the fixes the uw7 patch has.
> UnixWare 7 seems to have inherited some bugs from some
> of the Open Server 5 code.

After a lot of research, it appears that hylafax has uncovered a bug in
Unixware 7.1.  Several of the hylafax processes do seteuid()'s before
fork()ing.  There is an old Unixware bug where root processes honor the
MAXUP tuneable, which is not supposed to happen.  They have mostly fixed
it, except when you call seteuid() before a fork().  setuid() works
okay.  I have submitted a bug report to SCO.  In the mean time, I have
increased MAXUP to be equal to NPROC.

Jim Dossey                                       mailto:jfd@mercury.net

Project hosted by iFAX Solutions