HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Probemodem errors?


On Wed, 12 Jan 2000, George Zeigler wrote:

> Hello,
> > >George wrote:
> > > Hello,
> > > 	I ran probemodem.  I have tons of 
> > > "/bin/stty: standard input: unable to perform all requested operations"
> > > lines.  Also, a bunch of Errors.  Is this a concern?
> > > 	My modem is a LinkSys 10/100 + 56k combo PCMCIA card
> > > 	The output of probemodem is shown below.
> > 
> > Nico wrote:
> > We've been seeing stty errors on some systems mentioned lately:
> > Try running probemodem with "sh -x probemodem" for more details on
> > when the stty is failing.
> 	I ran sh -x probemodem and attached the results to this letter
> in case it's useful.  I clipped out the part dealing with ttyS 0 and inserted
> down below.

It looks like it's definitely the stty 0 part: Try reading the manual
page for "stty" on your system, and see what it says about "stty 0"

It's possible to comment out of your probemodem/faxaddmodem commands.

> > > Serial port that modem is connected to []? ttyS1
> > > Hmm, there does not appear to be an fuser command on your machine.
> > > This means that I am unable to insure that all processes using the
> > > modem have been killed.  I will keep going, but beware that you may
> > > have competition for the modem.
> > 
> > Why is it not finding a fuser command?
> 	Good question.  I will post this to the SuSE thread.  I tried it at the
> command prompt 
> fuser -u /root
> It works.
> I do not receive this if I do a simple
> probemodem ttyS1

What happens with "fuser /dev/ttyS1" issued as a root user? And do
you have another getty or something running on /dev/ttyS3, or /dev/modem
symbolically linked to /dev/ttyS1?

			Nico Kadel-Garcia
			Senior Engineer, CIRL 
			Mass. Eye and Ear Infirmary

Version: 2.6.2


Project hosted by iFAX Solutions