HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Please help : Phase D error



I have installed Hylafax 4.0pl2-3rh5 on a redhat 6.0 with an external
Sportser 28.8 faxmodem.
When i run faxaddmodem, it detects a Class2.0 modem, and everything seems to
be ok

I have set up WHFC on a win95b client, and send faxes from Word97. The fax
is getting through in the other end, but I get an error every time :

feb 04 10:11:44.87: [ 5439]: --> [7:CONNECT]
feb 04 10:11:44.87: [ 5439]: SEND begin page
feb 04 10:12:07.90: [ 5439]: SENT 35596 bytes of data
feb 04 10:12:07.90: [ 5439]: SEND 1D RTC
feb 04 10:12:13.24: [ 5439]: SEND end page
feb 04 10:12:13.24: [ 5439]: SEND send EOP (no more pages or documents)
feb 04 10:12:21.96: [ 5439]: --> [3:Hh]
feb 04 10:15:21.96: [ 5439]: REMOTE HANGUP: Unspecified Transmit Phase D
error, i
ncluding +FPHCTO timeout between data and +FET command (code 50)
feb 04 10:15:21.96: [ 5439]: <-- [7:AT+FKS\r]
feb 04 10:15:22.10: [ 5439]: --> [2:OK]
feb 04 10:15:22.10: [ 5439]: SEND: Unspecified Transmit Phase D error,
including
+FPHCTO timeout between data and +FET command; Giving up after 3 attempts to
send
same page "docq/doc11.ps;01", dirnum 0
feb 04 10:15:22.10: [ 5439]: <-- [5:ATH0\r]
feb 04 10:15:22.37: [ 5439]: --> [2:OK]
feb 04 10:15:22.37: [ 5439]: SESSION END


The config.ttyS1 is:
# $Id: usr-2.0,v 1.7 1996/06/24 02:58:42 sam Rel $
#
# Configuration for using the Class 2.0 command interface
# with a USR v.34 Courier or Sporster modem.
# RTS/CTS flow control is used default.
#
CountryCode:            47
AreaCode:               0
FAXNumber:              "+47 67911760"
LongDistancePrefix:     0
InternationalPrefix:    00
DialStringRules:        etc/dialrules.europe
ServerTracing:          1
SessionTracing:         11
RecvFileMode:           0600
LogFileMode:            0600
DeviceMode:             0600
RingsBeforeAnswer:      100
SpeakerVolume:          on
GettyArgs:              "-h %l %s"
LocalIdentifier:        "Electrocompaniet AS"
TagLineFont:            etc/lutRS18.pcf
TagLineFormat:          "From %%l|%c|Page %%p of %%t"
MaxRecvPages:           25
#
#
# Modem-related stuff: should reflect modem command interface
# and hardware connection/cabling (e.g. flow control).
#
ModemType:              Class2.0        # use class 2.0 interface
ModemRate:              38400           # DCE-DTE communication rate
ModemFlowControl:       rtscts          # XON/XOFF flow control assumed
#
ModemNoFlowCmd:         AT&H0&I0&R1     # setup modem for no flow control
ModemHardFlowCmd:       AT&H1&I0&R2     # setup modem for hardware flow
control
ModemSoftFlowCmd:       AT&H2&I2&R1     # setup modem for software flow
control
#
ModemSetupDTRCmd:       ATS13=1&D2      # setup so DTR drop resets modem
ModemSetupDCDCmd:       AT&C1           # setup so DCD reflects carrier (or
not)
ModemResultCodesCmd:    ATQ0X4          # enable extended result codes
#
# NB: adaptive answer only seems to work properly when
#     the modem is left idling in Class 2.0
#
ModemSetupAACmd:        AT+FAA=1
#
# Set modem speaker volume commands: OFF QUIET LOW MEDIUM HIGH.
# Note that we both turn the speaker on/off and set volume.
#
ModemSetVolumeCmd:      "ATM0 ATM1 ATM1 ATM1 ATM1"
#
# Modem does not support HDLC frame tracing; we add this just
# to eliminate spurious ERROR results that confuse the naive.
#
Class2BUGCmd:           AT+FBU=0
#
# The modem doesn't support copy quality checking, even though it
# returns (0-2,0-2) for AT+FCQ=?; therefore we override the query
# response so that the server will do copy quality checking.
#
Class2CQQueryCmd:       !(0),(0)        # override modem response
#Class2BORCmd:           AT+FBO=0        # bit order for phase B/C/D
(direct)
#Class2DCCQueryCmd:     "!(0,1),(0-3),(0-4),(0-2),(0),(0),(0),(0-7)"

By the way, the modem is connected via the analog port of an Zyxel Prestige
ISDN Router, cause we don't have any analogue lines.

Regards, Raymond Holmen
raholmen@online.no





Project hosted by iFAX Solutions