HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] Could not reopen converted document to verify format

At 12:32 PM 11/23/00 -0500, David Ronis wrote:
>I recently upgraded gs and several libraries on an i686-linux-gnu box
>and managed to break hylafax.  I get the message in the subject line
>when I submit a postscript document to be faxed (I use tkhylafax as an
>interface).  Grepping the source code shows that this is caused by a
>failure in TIFFopen. 
>I'd posted this before as a bug report and someone replied suggesting
>that the problem was with me not using the most recent version of
>libtiff; however, after upgrading to 3.5.5, making sure that all old

That someone was me.  My suggestion wasn't that you were using an old
version of libtiff, but rather that I had corrected an identical issue just
a week ago which I believe was caused by conflicting versions of libtiff
present on the system.  I didn't mean to indicate that this was certainly
the issue you were facing - merely a suggestion.

>versions of the library and include files were deleted, and rebuilding
>and installing hylafax from scratch using the CVS sources, the problem
>didn't go away.  At least, it didn't while I was testing as a regular
>user.  When I tried the test as root, things worked; clearly there is
>a file/directory permission issue here (although, hfaxd is 4755).
>Here's how the spool/fax directory is set up.

Your /var/spool/fax directory is set up identical to mine.

Remember that the HylaFAX daemons run the show regardless of who sends the
fax, using its own permissions, irrespective of the sender's permissions
(except the permission to fax or not or to view faxes or not - which is a
different thing).

I think you're looking in the wrong place for the answer.  If as root:

sendfax -d 1234567 /etc/hosts

functions properly, then I don't know of a way that HylaFAX could have a
problem with the same command when issued by any other user on the system.
My guess would be that tkhylafax is causing the problem somehow.


____________________ HylaFAX(tm) Users Mailing List _______________________
 To unsub: mail -s unsubscribe hylafax-users-request@hylafax.org < /dev/null

Project hosted by iFAX Solutions