HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

[hylafax-users] Some HylaFAX questions,

Hi every one,

Using Redhat 7.0 and hylafax-4.1beta3-1rh7.i386.rpm RPM.
Redhat is not an upgrade from previous versions.
I am also using a USR internal 28.8 modem.
I saw in some docs that this modem is supposed to be
installed as class 1 modem. Right now it is installed as
class 2.0. It works fine as far as I can see even in class 2.0.
I tried with class 1 but I can't send faxes any more. I could receive
faxes with class 1.
All the files related to Hylafax are stored in the default
directory: /var/spool/fax/bin or etc or config and so on.
also under /usr/share/fax/files

I have read man pages for ps2fax but when I want to use it 
it gives me some error messages:

[root@shell bin]# ./ps2fax -1 /usr/share/fax/faxcover.ps -o newfile

FATAL ERROR: /var/spool/fax/bin/etc/setup.cache is missing!

The file /var/spool/fax/bin/etc/setup.cache is not present.  This
probably means the machine has not been setup using the faxsetup(1M)
command.  Read the documentation on setting up HylaFAX before you
startup a server system.

Then I realised that there is not such a directory as
/var/spool/fax/bin/etc/setup.cache so I created /bin/etc and I copied the
setup.modem and setup.cache from /var/spool/fax/etc/setup.* to that

Now when I issue the command ps2fax some file, it gives me some other
error messages:
[root@shell bin]# ./ps2fax -1 /usr/share/fax/faxcover.ps -o new
Error: /undefined in comments
Operand stack:
   413.663   29   141.336   189
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop
.runexec2   --nostringval--   --nostringval--   --nostringval--   2
%stopped_push   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:910/941(G)--   --dict:0/20(G)--   --dict:96/200(L)--
Current allocation mode is local
Current file position is 9041
GNU Ghostscript: Unrecoverable error, exit code 1

What am I missing here?

Let's say if I want to send a MS Word file sometrhing.doc
file. How can I send it.
I tried but it gives me conversion error message.
How can it be done?
I don't have problem with pdf files or ascii files.
I beleive these files are converted to tiff files automatically by 

Sorry for the lenth of this e-mail.

Any help is welcome,



This e-mail is sent by using Linux Redhat and Pine.

____________________ HylaFAX(tm) Users Mailing List _______________________
 To unsub: mail -s unsubscribe hylafax-users-request@hylafax.org < /dev/null

Project hosted by iFAX Solutions