HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] faxaddmodem won't see the modem

At 01:26 PM 4/4/01 +0200, Eric Veldhuyzen wrote:
>On Wed, Apr 04, 2001 at 08:55:57PM +1000, Robert Colquhoun wrote:
> > I noticed Eric tried this, but at a very high speed 115K i think, maybe if
> > he has another go perhaps at 38400 or 9600 he might have more luck.
>Yes, I tried this first with the old version, and that one didn;t
>complain. The 4.1 Btea 3 version complains that this speed is non
>standard, so I tried it at lower speeds, but it gave me the same result.

Yes i think faxaddmodem had some fiddling between the two versions to try a 
get rid of an error message, unfortunately at the moment i can't remember 
the exact changes, should probably go and have a look at the cvs history.

 > Finally could he post the output of stty -a < /dev/ttyXX  and also

># stty -a < /dev/ttyS1
>speed 9600 baud; rows 0; columns 0; line = 0;
>intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^A; eol = <undef>; eol2 
>= <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
>lnext = ^V; flush = ^O; min = 0; time = 10;
>-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts
>-ignbrk -brkint ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon 
>-ixoff -iuclc -ixany -imaxbel
>-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 
>vt0 ff0
>-isig -icanon -iexten -echo -echoe echok -echonl -noflsh -xcase -tostop 
>-echoprt -echoctl -echoke

On an old version of linux(for a different serial port) these parameters 
work for me:

[root@linux3 rjc]# stty -a < /dev/ttyS2
speed 38400 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;eol2 = 
<undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread clocal crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon 
-ixoff -iuclc -ixany -imaxbel
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 
vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop 
-echoprt -echoctl -echoke

....from memory though the above settings might not matter as i think 
faxadduser uses stty to override all the params anyway.

> > setserial -a, just to see if there are any weird line params set.
># setserial -a /dev/ttyS1
>/dev/ttyS1, Line 1, UART: 16550A, Port: 0x02f8, IRQ: 3
>         Baud_base: 115200, close_delay: 50, divisor: 0
>         closing_wait: 3000
>         Flags: spd_normal skip_test

[root@linux3 rjc]# setserial -a /dev/ttyS2
/dev/ttyS2, Line 2, UART: 16550A, Port: 0x03e8, IRQ: 5
         Baud_base: 115200, close_delay: 50, divisor: 0
         closing_wait: 3000, closing_wait2: infinte
         Flags: spd_normal skip_test

> > PS Also try attaching the modem to another serial port if possible if he
> > hasn't already tried that(need to eliminate faulty serial port hardware).
>That's a bit of a problem since that would require another cable (9pin
>instead of 25pin). And I think I have found the problem, I just don't
>know how to solve it. The process that is put in the background in
>the onDev function exits before any output is generated by the serial
>port. Probably even before any data is sent to the serial port.

Would that be one of the stty calls? if so which one?

Could you also paste the output of 'stty --version'

- Robert

____________________ HylaFAX(tm) Users Mailing List _______________________
 To unsub: mail -s unsubscribe hylafax-users-request@hylafax.org < /dev/null

Project hosted by iFAX Solutions