HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

[hylafax-users] Never ending Password prompt

Any help here would be great.  I am using a debian potato system.  It
installs as standard v4.0p12 of hylafax (according to faxsetup.)  I am
so far unable to get hylafax to work.  "faxsetup" was run automatically
when I installed the binaries.  I am quite confident that this worked
properly.  I am sure my modem is connected and working properly because
I have check with minicom.  I ran faxaddmodem and it appears that this
went OK.  At this point it may not be relevant because I just can't seem
to get hylafax to let me contact the server for apparent password
reasons?  I have added my user name to the group fax which on my system
is gid 21.  I don't think this matters because this group is a reminent
of an efax install.  I have noticed that there is no user fax on my
system and this seems inconsistent with online documentation.  When I
tried adduser fax I got an error "adduser: The group `fax' already
exists."  Is this my problem?  When I got rid of the group fax nothing
seems to have changed.  I have made sure that my 

/var/spool/fax/etc/hosts is chmod 600.  

-rw-------    1 root     root           15 Jun  5 00:56 hosts

Note that /etc/hylafax/hosts is the actual file on my system and 

/var/spool/fax/etc is a symbolic link to /etc/hylafax

The error I keep getting is as follows.  Every hylafax command I use is
rejected by a password prompt.  If I type "faxstat" for example I get
prompted "Password:".  If I just press enter I get

Login failed: 500 'PASS ': Syntax error, expecting password.

If I try use my users password I get 

Login failed: 530 Login incorrect.

I have tried copying my hashed password from my /etc/shadow file into my
/etc/hylafax/hosts file.  Example



This does not work.  I have tried adding a user to the hosts file with
no password like so:



but this doesn't work.  What do I have to do to be able to at least get
faxstat to work?

I tried login to the hylafax server directly by using telnet localhost
4559 but I got the same results here as well.

Please help.


____________________ HylaFAX(tm) Users Mailing List _______________________
  To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
 On UNIX: mail -s unsubscribe hylafax-users-request@hylafax.org < /dev/null

Project hosted by iFAX Solutions