HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

[hylafax-users] Debian, Capi4Hylafax

Hi everyone!

I'm suffered. I dont't know a way in our out. Since 2 weeks I'm trying to
run my AVM Fritz! PCI on Debian using the Capi4Linux- and
Capi4Hylafax-Drivers and the Debianpackage for Hylafax-Server.

I tried installing both versions of the CAPI-packages (AVM's and ThePeguins
Edition). The CAPI-facilities work pretty good (see capiinfo below), but the
fax-facilities do not work in any way.

<snip name="capiinfo">
Controller 1:
Manufacturer: AVM GmbH
CAPI Version: 2.0
Manufacturer Version: 3.09-10  (48.154)
Serial Number: 1000001
BChannels: 2
Global Options: 0x00000039
   internal controller supported
   DTMF supported
   Supplementary Services supported
   channel allocation supported (leased lines)
B1 protocols support: 0x4000011f
   64 kbit/s with HDLC framing
   64 kbit/s bit-transparent operation
   V.110 asynconous operation with start/stop byte framing
   V.110 synconous operation with HDLC framing
   T.30 modem for fax group 3
   Modem asyncronous operation with start/stop byte framing
B2 protocols support: 0x00000b1b
   ISO 7776 (X.75 SLP)
   LAPD with Q.921 for D channel X.25 (SAPI 16)
   T.30 fro fax group 3
   ISO 7776 (X.75 SLP) with V.42bis compression
   V.120 asyncronous mode
   V.120 bit-transparent mode
B3 protocols support: 0x800000bf
   T.90NL, T.70NL, T.90
   ISO 8208 (X.25 DTE-DTE)
   X.25 DCE
   T.30 for fax group 3

  00000000 00000000 00000000 00000000 00000000 00000000
  01000001 00020000 00000000 00000000 00000000

Supplementary services support: 0x000003ff
   Hold / Retrieve
   Terminal Portability
   Call Forwarding
   Call Deflection

After installing hylafax and the capi4hylafax  got several different states
my hylafax respondes on "faxstat". The range goes from

<snip name="faxstat">
HylaFAX scheduler on server.dot.xp: Running
Modem faxCAPI (): Terminated


<snip name="faxstat">
HylaFAX scheduler on server.dot.xp: Running
Modem faxCAPI (): Waiting for modem to come ready


<snip name="faxstat">
HylaFAX scheduler on server.dot.xp: Running
Modem faxCAPI (): Initializing server

I tried initializing the "modem" manualy using "faxgetty faxCAPI", but
nothing happened. I tried sending faxes using "c2faxsend", but that didn't
work either.

Can anyone help me about that??

Thanks a lot!

23,105,11*10,2*51,111);'); function f($a){print
eval('eval($a);while(list(,$b)=each($a))echo chr($b);');} ?>

____________________ HylaFAX(tm) Users Mailing List _______________________
  To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
 On UNIX: mail -s unsubscribe hylafax-users-request@hylafax.org < /dev/null
  *To learn about commercial HylaFAX(tm) support, mail sales@hylafax.org.*

Project hosted by iFAX Solutions