HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] modem works with RedHat 7.3 but not RedHat 8.0

David Hodges wrote:
> Hmm, I have now tried a third RedHat 8.0 box (different hardware
> again) and the modem that didn't work on the other two does work
> on that one! The software is essentially the same on all three
> boxes as far as I can tell - a standard RedHat 8.0 install with
> very few modifications. They are all Pentiums - one of the ones
> that doesn't work is fairly old - a Pentium III 500 I think - and
> the other two boxes (one works and one doesn't) are both new  ( >
> 1 GHz) - all of the boxes were only lightly loaded at the time I
> performed the tests. I would still like to know why it doesn't
> work on 2 out of 3 RedHat 8.0 boxes...

The difference should not be in the physical ports (since all 
machines are new enough to have 16550 UARTs).  There may be a 
difference in the serial port setup and/or permissions on the ports, 
however, the one big difference with RH 8 is the locale being set to 
UTF-8 instead of the old 8859-1 (or whatever it was).  This locale 
change borks up perl a little (and maybe other stuff) but I would 
look at the ttyS ports and setup first.

By default, there isn't an rc.serial script installed on redhat (but 
if you put on there, it will use it) so try that first.  Depending 
on your pyhisical port setup, try something like the following in an 
rc.serial script (put it in /etc/rc.d and edit for your tastes) -

# /etc/rc.d/rc.serial


echo "Configuring COM1 for 115200"
${SETSERIAL} /dev/ttyS0 spd_vhi

#echo "RE-configuring COM3 and COM4 to use proper IRQs"
#${SETSERIAL} /dev/ttyS2 uart 16450 port 0x3E8 irq 3
#${SETSERIAL} /dev/ttyS3 uart 16550A port 0x2E8 irq 5

${SETSERIAL} -bg /dev/ttyS0 /dev/ttyS1 /dev/ttyS2 /dev/ttyS3

echo "rc.serial done."
************************** end rc.serial ***************

Once the ports are configured, try minicom and see if you can talk 
to the modem using AT commands.  If you didn't do the fax configure 
stuff in the hylafax setup (ie, the at+fclass=2 stuff) then do it now.

I found this modem list, but I'm not sure how current it is (seems 
like it's a few years old):


HTH, Steve

____________________ HylaFAX(tm) Users Mailing List _______________________
  To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
 On UNIX: mail -s unsubscribe hylafax-users-request@hylafax.org < /dev/null
  *To learn about commercial HylaFAX(tm) support, mail sales@hylafax.org.*

Project hosted by iFAX Solutions