HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] Consistent failure in sending faxes

Lee Howard wrote:

On 2003.11.11 17:51 Michael Evans wrote:

Lee Howard wrote:

This indicates that either the modem's V.29 is broken or that you need to switch flow control. If you're using "ModemFlowControl: xonxoff" then set it to "rtscts" or vice versa. Then try. If that doesn't work

(I tried it, but it didn't work - exactly the same result as before.)

Okay, so it's something else.

then you may want to try sending to this destination at 4800 bps and see if it goes through. If it does, then maybe the V.29 modulator is broken if you can't ever fax with V.29 to anywhere. You can disable V.29 with HylaFAX, if needed.

How is this done?

To send at 4800 bps use the 'sendfax -B 4800' option.

To disable V.29 you have to force the Class1TMQueryCmd and Class1RMQueryCmd options. See 'man hylafax-config' for details. You should try the sendfax option first, though.

Do you have this trouble sending to all destinations or just this one?



In answer to the last question: I don't know, I haven't had the chance to try sending to different destinations.

I don't think 'sendfax -B 4800' is going to work for us, as everyone is using Windows machines and I plan to have them send through WHFC. Asking them to run a SSH session and enter text on a command line just won't work.

So I'd like to try the other option, that is, get hylaFAX to avoid the higher speeds. Forgive my density, but I looked at 'man hylafax-config,' and I just don't understand what is meant by "force the Class1TMQueryCmd and Class1RMQueryCmd options." What is being "forced" here? The default setting of AT+FTM=? is what is listed in the modem documentation for querying the transmit speed, and explicitly giving this default value in the modem config file has no effect. On the other hand, if you replace the ? with a number (i.e., 48 which corresponds to 4800 bps), then this is the command for setting the transmit speed.

But if I do this, hylaFAX won't initialize the modem. var/log/messages shows an ERROR . The modem returns "OK" in response to the speed being set when hylaFAX appears to be expecting a comma-delimited list of possible speeds in response to its inquiry. Then it sits there in an infinite state of "Waiting for modem to come ready."

I am clearly missing something here.


Michael Evans

____________________ HylaFAX(tm) Users Mailing List _______________________
 To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null
 *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxxxxx*

Project hosted by iFAX Solutions