HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] Incoming fax from older machines are unreadable


47.log does not use ECM.
48.log does use ECM ("REMOTE wants T.30 Annex A, 256-byte ECM").

The reason that ECM makes a difference is because when ECM is not used the TIFFWriteEncodedStrip function is used, and when ECM is used the TIFFWriteRawStrip function is used. (The difference is that the former encodes the strip and the latter one doesn't. We decode and then reencode in the copy-quality-correction process which is not done when ECM is performed.)

So, I'm rather sure that you still are using a faulty libtiff.

Make sure that you patch libtiff and rebuild and reinstall it in the same manner that it was originally installed. If you installed libtiff first with RPM or some other binary package, and then if you patch a tarball installation you're likely to end up with two distinct installations of libtiff on your system.

Also note that you may need to recompile HylaFAX after updating the TIFF libraries. It's always a wise idea to recompile any packages that depend on libraries that you update.


On 2005.01.28 07:28 Theo Chao wrote:

I was running libtiff v.3.6.1 without the patch and saw bug 500. I applied the patch and then reinstalled libtiff which didn't fix it.

Actually, after I sent this email yesterday, I upgraded to HylaFax 4.2.1 with libtiff v.3.7.0. However, I still have the problem. How can I be sure what version of libtiff is being run by HylaFax?

I don't see anything about error correction in either type of log file. Although I didn't say that the fax that works contains "RECV received frame number" lines.

I'm sending examples of two of my logs. 47.log is the fax that doesn't work and 48.log is the fax that does work.


----- Original Message ----- From: "Lee Howard" <faxguy@xxxxxxxxxxxxxxxx>
To: "Theo Chao" <theochao@xxxxxxxxxxx>
Cc: <hylafax-users@xxxxxxxxxxx>
Sent: Thursday, January 27, 2005 6:57 PM
Subject: Re: [hylafax-users] Incoming fax from older machines are unreadable

On 2005.01.27 11:00 Theo Chao wrote:

I'm running HylaFax 4.2.0 with libtiff v3.6.1 with the patch. Most of
the time incoming faxes come through fine. However, we've noticed
that older machines that send faxes to us will not come through
correctly (the entire fax is all black). The main difference between
the logs for faxes that work and those that don't work is that "REMOTE
wants 1-D MH" in the faxes that don't work.

Does anyone have any suggestions for what's going wrong?

Are you absolutely, positively sure that you have a patched version of libtiff 3.6.1?

You say that the main difference between the logs is "REMOTE wants 1-D MH". How about ECM (error correction)? Do the faxes that come out fine use error correction and the ones that don't not have it?


____________________ HylaFAX(tm) Users Mailing List _______________________ To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Project hosted by iFAX Solutions