HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] Adding a new fax device without faxaddmodem

Charles Duffy wrote:
> Given these things, I'm basically creating a new modem via this
> method:
> - create etc/config.<device>
> - Create FIFO.<device>
> - Run "faxmodem <device>"

This works nicely, for the currently-running faxq instance. After a restart, however, faxq doesn't use the modem until "faxmodem <device>" is run.

On initialization, I see evidence that faxQueueApp::scanForModems() is invoked, via the following strace output:

stat("FIFO.ttyS4", {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
stat("etc/config.ttyS4", {st_mode=S_IFREG|0644, st_size=914, ...}) = 0

...and, given that both these stat calls succeed, I would *expect* to see faxq make use of the modem in question for sending outgoing jobs.

I am *guessing* that the modem is in fact added, but never has its state changed from DOWN to READY? I'd expect that this would normally happen during a call to setCapabilities() -- but I don't see anywhere faxq calls setCapabilities except when processing an incoming message on the FIFO.

Again, some enlightenment would be appreciated. Thanks!

(This is a send-only environment without faxgetty running).

____________________ HylaFAX(tm) Users Mailing List _______________________ To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Project hosted by iFAX Solutions