HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

[hylafax-users] FC6 unable to receive fax

Good day;

It's been over 8 years since I've tried to use Hylafax,
and obviously, I'm missing something simple and crucial.

I have been able to send faxes fine. However, I've been
unable to receive a single fax. Each test attempt from
the 'sending' fax machine just bails as soon as the modem

I've tried 3 modems. Each one with the same result.

Currently, I'm trying a rather generic rockwell chipset

contents of my config.ttyS0


CountryCode:            1
AreaCode:               XXX
FAXNumber:              +1.XXX.XXX.XXXX
LongDistancePrefix:     1
InternationalPrefix:    011
DialStringRules:        etc/dialrules
ServerTracing:          3
SessionTracing:         11
RecvFileMode:           0600
LogFileMode:            0600
DeviceMode:             0600
RingsBeforeAnswer:      1
SpeakerVolume:          medium
GettyArgs:              "-h %l dx_%s"
LocalIdentifier:        TestFax
TagLineFont:            etc/lutRS18.pcf
TagLineFormat:          "From %%l|%c|Page %%P of %%T"
MaxRecvPages:           25
ModemType:              Class1          # use this to supply a hint
ModemRate:              19200           # rate for DCE-DTE communication
ModemFlowControl:       rtscts          # default
ModemNoFlowCmd:         AT&K0           # setup no flow control
ModemHardFlowCmd:       AT&K3           # setup hardware flow control
ModemSoftFlowCmd:       AT&K4           # setup software flow control
ModemSetupDTRCmd:       AT&D2           # setup so DTR drop resets modem
ModemSetupDCDCmd:       AT&C1           # setup so DCD reflects carrier
(or not)
ModemMfrQueryCmd:       !Rockwell
ModemModelQueryCmd:     !RC288DPi
ModemRevQueryCmd:       ATI3            # product information
ModemDialCmd:           ATDT%s          # T for tone dialing


faxgetty is running in a rather basic manner;

]# ps aux | grep faxgetty
uucp     19430  0.0  0.3   6944  1692 pts/2    S+   Feb05   0:00
/usr/sbin/faxgetty ttyS0

Since there are no howtos any more that I can find, I really don't know
where to even begin. The 'quick start guides' on the wiki don't go
anywhere, and I'm quite lost.

I don't know how to up the verbosity for faxgetty, and for that
matter, I'm not even sure how faxgetty is supposed to behave.

I'm running FC6

All clues appreciated.

____________________ HylaFAX(tm) Users Mailing List _______________________
  To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
 On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null
  *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Project hosted by iFAX Solutions