HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] IAXModem With HylaFAX

Hi Vinicius, I'm passing you my configuration:
first of all, make sure you get iaxmodem and hylafax configured as shown in this page:
You dont have to compile sources the apt goes fine with debian
Here is a different extension as you have:

exten => fax,1,Dial(IAX2/200)

This one captures fax and send it to the 200 exten inside the iax.conf
Another thing is to change this setting in /etc/asterisk/zapata.conf


With this one, previuosly, removing the zaptel and wctdm modules (rmmod zaptel, rmmod wctdm) and then loading again (modprobe zaptel, modprobe wctdm.

I have the same configuration and I receives faxes perfectly.

Another good thing is under asterisk console (asterisk -r) set verbose to 3 so you can follow what is going on with the call.

Vinicius Teixeira Coelho wrote:
i'm already wake this question on asterisk forum, but not solve my problem =(
well, i try again install the hylafax and iaxmodem, i notice this time when the faxsetup is trying the search for the modem speed show this message:
Probing for best speed to talk to modem: 38400 19200 9600 4800 2400 1200
Unable to deduce DTE-DCE speed; check that you are using the
correct device and/or that your modem is setup properly. If
all else fails, try the -s option to lock the speed.

the faxsetup don't configure corret me modem?


On 6/15/07, *Andres Paglayan* <andres@xxxxxxxxxxxx <mailto:andres@xxxxxxxxxxxx>> wrote:

    it might be a question better suited for asterisk forum,
    what's your asterisk console showing while the call is in progress,
    $ asterisk -vvvr

On Jun 15, 2007, at 1:11 PM, Vinicius Teixeira Coelho wrote:

    Hi, i'm trying to configure hylafax to work with asterisk using
    iaxmodem in a server with debian. i fond a tutorial where say:
    #>apt-get install hylafax-server hylafax-client
    #>apt-get install iaxmodem
    #>iaxmodem ttyIAX0 &
    select ttyIAX0
    #>/etc/init.d/hylafax start

    in the extensions.conf i put:
    exten => 7,1,Dial(IAX2/ttyIAX0/${EXTEN})

    but when a call to the server, the hylafax don't kickup?
    i don't know what i'm doing wrong, can anyone help?

ps: sorry my english!
-- Vinicius Teixeira Coelho

Vinicius Teixeira Coelho

____________________ HylaFAX(tm) Users Mailing List _______________________
 To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null
 *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Project hosted by iFAX Solutions