HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

[hylafax-users] Capi4Hylafax and AVM Fritz!Card PCI

Hi all,

Several years ago, I was happy to discover an easy way to circumvent all those pesky fax-modem compatibility problems: just use capi4Hylafax with an AVM Fritz!Card PCI to work as a software fax. The necessary software support for it is unfortunately closed source, but it allowed me to compile a module for the 2.6.8 Linux kernel on my Debian sarge without any problems.

However, now that I've upgraded the server to Debian etch and kernel 2.6.18, it seems like that closed source issue has come back to roost: the AVM software refuses to compile! See the results in the install.log below.

Seeing as there haven't been any updates for that AVM software since 2005, are
these cards now considered useless for current Hylafax systems on Linux? If
not, I'd be grateful if someone could point me in the direction of a solution. If so, what are currently the favored alternatives?



==== install.log ==========================

AVM ISDN-Controller, 1
Card: FRITZ!Card PCI
Driver: fcpci
Startup: Wed Dec 19 02:52:34 CET 2007
Install for FRITZ!Card PCI
Welcome to the FRITZ!Card PCI driver installation!
Installing for kernel version 2.6.18-5-k7
CHK:pppd version 2.4.4
CHK:pppd version status 0
PRE:Looking for file install_passive-d.php...
PRE:Looking for file install_passive-e.php...
MAIN:Generating FRITZ!Card PCI driver for kernel 2.6.18-5-k7...
make: Entering directory `/root/fcpci/fritz91/src'
make -C /lib/modules/2.6.18-5-k7/build SUBDIRS=/root/fcpci/fritz91/src modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.18-5-k7'
CC [M] /root/fcpci/fritz91/src/main.o
In file included from /root/fcpci/fritz91/src/queue.h:27,
from /root/fcpci/fritz91/src/tables.h:31,
from /root/fcpci/fritz91/src/driver.h:31,
from /root/fcpci/fritz91/src/main.c:45:
/root/fcpci/fritz91/src/tools.h:74: error: expected identifier or ?(? before ?typeof?
/root/fcpci/fritz91/src/tools.h:74: error: expected ?)? before ?__xchg?
make[2]: *** [/root/fcpci/fritz91/src/main.o] Error 1
make[1]: *** [_module_/root/fcpci/fritz91/src] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.18-5-k7'
make: *** [fcpci.ko] Error 2
make: Leaving directory `/root/fcpci/fritz91/src'
MAIN:Error while making src/fcpci.ko, see install.log!
MAIN:Could not generate src/fcpci.ko!


____________________ HylaFAX(tm) Users Mailing List _______________________ To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Project hosted by iFAX Solutions