HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] Emails not being sent, but using faxrcvd on the command line works

* Augusto Bortoluzzi <bortoluzzi@xxxxxxx> [080401 11:16]:
> But when I receive a fax, it is correctly decoded and placed under
> "recvq" directory, but it is not sent.
> I spent a lot of time checking permission and testing, I had a look here
> http://www.hylafax.org/content/FAQ#Why_aren.27t_emails_being_sent_when_using_faxrcvd_on_the_command_line_works.3F
> and also tried with "uucp" group.
> I really don't know what to do since exim runs smoothly when
> I launch faxrcvd by command line as shown above.

The gneral way to debug somethign like this is to "wrap" faxrcvd.

Create a simple wrapper in /tmp/faxrcvd-wrapper.sh:

	echo "faxrcvd $*" > /tmp/faxrcvd-$$.log
	echo "==================================" >> /tmp/faxrcvd-$$.log
	exec /bin/sh -x bin/faxrcvd "$@" >> /tmp/faxrcvd-$$.log 2>&1

Make sure it's executable (chmod 755 /tmp/faxrcvd-wrapper.sh), and set
faxgetty to use it:
		FaxRcvdCmd: /tmp/faxrcvd-wrapper.sh

You should see faxgetty use this wrapper now, and you should have files
appear in /tmp:

And we can start looking at those to see why things aren't working.
Feel free to send one directly to me.


Aidan Van Dyk                                             aidan@xxxxxxxx
Senior Software Developer                          +1 215 825-8700 x8103
iFAX Solutions, Inc.                                http://www.ifax.com/

Attachment: signature.asc
Description: Digital signature

Project hosted by iFAX Solutions