HylaFAX The world's most advanced open source fax server

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hylafax-users] USR USB Modem "wedged"?

Hi Dominique,

thanks for your reply.

> Do you have faxgetty running for that modem?

faxgetty is started via /etc/init.d/hylafax, yes. I checked - it is
running (ps -e | grep fax shows faxgetty) after I start hylafax until the
following error message shows up in the log appears:

>> Dec 14 07:41:38 server FaxGetty[4856]: Unable to setup modem on
>> /dev/ttyACM0; giving up after 2 attempts
>> Dec 14 07:41:38 server FaxGetty[4856]: CLOSE /dev/ttyACM0

Then faxgetty terminates.

I get the same error messages, if I start faxgetty directly with "faxgetty

There must be some difficulties with faxgetty accessing the USB modem.
minicom works fine. Any settings I could/should try for faxgetty?

etc/config.ttyACM0 looks like this:

CountryCode:		49
AreaCode:		7031
FAXNumber:		+497031268185
LongDistancePrefix:	0
InternationalPrefix:	00
DialStringRules:	etc/dialrules
ServerTracing:		1
SessionTracing:		11
RecvFileMode:		0644
LogFileMode:		0644
DeviceMode:		0666
RingsBeforeAnswer:	1
SpeakerVolume:		off
GettyArgs:		"-h %l dx_%s"
LocalIdentifier:	"bla"
TagLineFont:		etc/lutRS18.pcf
TagLineFormat:		"From %%l|%c|Page %%P of %%T"
PercentGoodLines:	90
MaxConsecutiveBadLines:	8
MaxRecvPages:		100
ModemType:		Class1		# use class 1 interface
ModemRate:		19200		# rate for DCE-DTE communication
ModemFlowControl:	xonxoff		# software flow control
ModemSetupDTRCmd:	ATS13=1&D2	# setup so DTR drop resets modem
ModemSetupDCDCmd:	AT&C1		# setup so DCD reflects carrier (or not)
ModemNoFlowCmd:		AT&H0&I0&R1	# setup modem for no flow control
ModemHardFlowCmd:	AT&H1&I0&R2	# setup modem for hardware flow control
ModemSoftFlowCmd:	AT&H2&I2&R1	# setup modem for software flow control
ModemResultCodesCmd:	ATQ0X4		# enable result codes
ModemMfrQueryCmd:	!USR
ModemModelQueryCmd:	ATI3
ModemRevQueryCmd:	ATI7		# XXX returns a multi-line result
Class1NFLOCmd:		AT&H0&I0&R1	# setup modem for no flow control
Class1HFLOCmd:		AT&H1&I0&R2	# setup modem for hardware flow control
Class1SFLOCmd:		""		# modem does this automatically
Class1ResponseWaitCmd:	AT+FRS=1	# wait after sending TCF for response
ModemSetupAACmd:	AT+FCLASS=0	# leave modem idling in class 0
ModemAnswerCmd:		AT+FCLASS=1A	# answer in Class 1
Class1SwitchingCmd:	"<delay\0727>"

FIFO.ttyACM0 does not exist.

Any idea on what I could try to tweak?

Thanks, Christian

____________________ HylaFAX(tm) Users Mailing List _______________________
  To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
 On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null
  *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Project hosted by iFAX Solutions