Hylafax Mailing List Archives

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

[hylafax-users] Problems with sending faxes with c2faxsend

[Sent to both the linux-avmb1 as the Hylafax mailinglist]


I have some problems with sending faxes with Fedora, Hylafax and my AVM B1
controller. Receiving faxes works without any problems. c2faxsend does try
to sent a fax, but it terminates again within a second. I found various
other people having the exact same problems, discussed in for example
http://www.kofler.cc/forum/forumthread.php?rootID=2719#2827. I have been
using the controller without any problems for almost two years now with the
same configuration, but to due a harddisk failure I had to reinstall my
complete machine. Fortunatly I had a backup of all the configuration and
data files, but that didn't include the driver and program stuff.

I have the following configuration:

Environment:	Fedora Core 2
Kernel:		Kernel 2.6.6
Hylafax:		4.1.8
Capi4Hylafax:	01.02.02 (from ftp.avm.de)
Capi4kutils:	2004-03-31 (from ftp.in-berlin.de)
Fax-number:	+31 72 5648905

My config.faxCAPI:

SpoolDir:               /var/spool/hylafax
FaxRcvdCmd:             /var/spool/hylafax/bin/faxrcvd
PollRcvdCmd:            /var/spool/hylafax/bin/pollrcvd
FaxReceiveUser:         uucp
LogFile:                /var/spool/hylafax/log/capi.log
LogTraceLevel:          0
LogFileMode:            0666
    HylafaxDeviceName:          faxCAPI
    RecvFileMode:               0666
    FAXNumber:                  +31.72.5648905
    LocalIdentifier:            "Xolphin"
    MaxConcurrentRecvs:         2
    OutgoingController:         1
    OutgoingMSN:                5648905
    SuppressMSN:                0
    UseISDNFaxService:          0
    RingingDuration:            0
        Controller:             1
        AcceptSpeech:           1
        UseDDI:                 0
        DDILength:              0
        IncomingMSNs:           5648905
        AcceptGlobalCall:       1

Permissions and stuff are set correctly. I tried other setups (kernel 2.4,
mungo.homelinux.org rpm's, mISDN, isdn4k-utils) too, but without any

When I start the capi environment by executing 'capiinit start' I get the
following error in /var/log/messages (this was introduced while I was
debugging my problem, however I don't know how to get rid of it again): 

capi20: Rev started up with major 68 (middleware+capifs)
b1: revision
b1dma: revision
PCI: Found IRQ 10 for device 0000:00:0b.0
b1pci: PCI BIOS reports AVM-B1 V4 at i/o 0xd800, irq 10, mem 0xe0001000
kcapi: Controller 1: b1pciv4-d800 attached
b1pci: AVM B1 PCI V4 at i/o 0xd800, irq 10, mem 0xe0001000, revision 4 (dma)
b1pci: revision
b1pciv4-d800: card 1 "B1" ready.
b1pciv4-d800: card 1 Protocol: DSS1
b1pciv4-d800: card 1 Linetype: point to multipoint
b1pciv4-d800: B1-card (3.11-03) now active
Debug: sleeping function called from invalid context at
in_atomic():1, irqs_disabled():0
Call Trace:
  [<0211691d>] __might_sleep+0x80/0x8a
  [<1a8fd3d6>] capi_ctr_ready+0x22/0xa3 [kernelcapi]
  [<1a90f01b>] b1dma_handle_rx+0x531/0x6b0 [b1dma]
  [<1a90f22d>] b1dma_handle_interrupt+0x93/0xf3 [b1dma]
  [<1a90f294>] b1dma_interrupt+0x7/0xd [b1dma]
  [<0210707e>] handle_IRQ_event+0x28/0x48
  [<02107311>] do_IRQ+0xf3/0x169
  [<0210403b>] default_idle+0x23/0x26
  [<02112590>] apm_cpu_idle+0xe4/0x121
  [<0210408c>] cpu_idle+0x1f/0x34
  [<02318612>] start_kernel+0x174/0x176
kcapi: card 1 "b1pciv4-d800" ready.

Everything seems to work alright, with the exception of sending faxes with
c2faxsend or Hylafax. Sending faxes with capisuite however isn't a problem (
I only don't want to use capisuite due the lack of a good Windows based
printing system (like for example http://winprinthylafax.sourceforge.net/)).

When I try to fax a fax with "c2faxsend -d 5648905 -f TIFF sendq/test.tif"
in the HylaFax directory I get the following message:

> Try to connect to fax number 5648905 in TIFF mode on controller 1.
> Dial and starting transfer of TIFF-File /var/spool/sendq/test.tif with
normal resolution.

The command is completed within a second (my phone rings only once (and I
tried my normal phone, and my cellular too)).

I did make a debug built, to find the exact problem, and this resulted in
the following message printed out:

CFaxSend - Constructor<
>CFaxSend - Constructor
CapiTrace: CAPI_REGISTER Success
CapiTrace: CONNECT_REQ(1)
CapiTrace: CONNECT_CONF(101)
CFaxSend - Destructor<
>CFaxSend - Destructor
[assertion failed: (CurState() == cs_Released) in Channel.cpp(82)]
[assertion failed: (GetState() == cs_Released) in CapiChan.cpp(85)]
[assertion failed: (GetPLCI() == IllegalPLCI) in CapiChan.cpp(86)]
[warning: (GetInitiator() == vFalse) in CapiChan.cpp(88)]
[assertion failed: (m_hCapiBase == vIllegalHandle) in CapiMsg.cpp(97)]
[assertion failed: (GetApplID() == IllegalApplID) in CapiMsg.cpp(98)]
[assertion failed: (m_RegisterState == REGISTER_STATE_RELEASED) in

Sending faxes from Hylafax itself results in the following message:

> Your facsimile job to 5648905 was not sent because:
>    An error occured while trying to establish the connection.
> The job will be retried at 20:11.
>   ---- Transcript of session follows ----
> Jun 13 20:06:07.91: [ 3193]: SESSION BEGIN 00000003 +31.72.5648905 Jun 13
20:06:07.91: [ 3193]: FAX FAX: JOB 3 DEST 5648905 COMMID 00000023 Jun 13
20:06:07.91: [ 3193]: Try to connect to fax number 5648905 in Hylafax mode
on controller 1.
> Jun 13 20:06:07.91: [ 3193]: Dial and starting transfer of TIFF-File
docq/doc3.ps;31 with fine resolution.
> Jun 13 20:06:08.91: [ 3193]: SESSION END

I have been debuggin this problem for several days now, but I can't find any
solution at all. I already contacted AVM about this but they are just saying
"We are very sorry, but we only support Suse".

Is there anyone that knows how to solve this irritating bug? I hope to hear
from you!

Kind regards,

Maarten Bremer

____________________ HylaFAX(tm) Users Mailing List _______________________
  To subscribe/unsubscribe, click http://lists.hylafax.org/cgi-bin/lsg2.cgi
 On UNIX: mail -s unsubscribe hylafax-users-request@xxxxxxxxxxx < /dev/null
  *To learn about commercial HylaFAX(tm) support, mail sales@xxxxxxxxx*

Report any problems to webmaster@hylafax.org

HylaFAX is a trademark of Silicon Graphics Corporation.
Internet connectivity for hylafax.org is provided by:
VirtuALL Private Host Services